
Figure www.factsage.com

Use Figure to manipulate, edit and plot figure and phase diagrams already 
calculated by FactSage.

The Figure module
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The Figure module

Click on Figure in the main
FactSage window.
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Figure Main Window

File name

Pixel coordinates of the cursor

Graphic coordinates of the cursor

Figure toolbar

Normal edition mode 
toolbar

Figure menu bar

If you don’t see the 
Figure edition toolbar, 
go to the menu View
and check Tool Bar.
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Figure Menu and Tool bars

The following three slides show the basic command 
environment of the Figure module.

A Menu bar and a Tool bar are available in order to 
perform the various tasks that are possible with Figure.
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Figure Menu Bar
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Figure Normal Edition Mode Toolbar

New
Open

Save

Close

Copy
Cut

Paste
Delete

Undo

Surperimposed Figure

Print
Page Setup

Zoom (magnifying glass)
Full Window Figure

Zoom

Selected Object
Identification
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Figure Toolbar

normal edition mode

phase equilibrium mode

2-phases tie-lines mode

stable phases label mode

Close the new line

Open a new line

Add Line

Add Label

Add Symbol

Phase diagram program

Click to disable the mouse activated mode 
for the entry of points coordinates of a line.

Click to enable the mouse activated mode 
for the entry of points coordinates of a line.

Keyboard mode for the entry of points coordinates 
of a line (opens the Add Line window).

Opens the Add Label window.

Opens the Add Symbol window.

Select to enable the mouse activated 
labeling (with a click) of stable phases.

Select to enable the mouse activated 
drawing (with a click) of 2-phases tie-lines.

Click to enable the Show results window 
mode to see the output of the calculation of a 
phase diagram at the selected coordinates.

Click to enable the normal edition mode
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Opening and editing a FIGure file

Graphical output from calculational modules such as 
Reaction, Predom, Equilib or Phase Diagram can be 
post-viewed and edited using the Figure module.

Such output is stored in files with the extension FIG. Use 
the Open File dialog box to select the desired file from the 
folder in which it is stored. The pre-view window helps you 
to select the file you want.

Once the file is opened the figure is displayed on the 
screen and ready for further operations.

The following two slides show how to select and open a 
figure file.
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Opening a figure file
Select File > Open… from the menu bar 
or click on the Open icon in the standard 
toolbar.  You will be asked if you want to 
save the current file.

For example, choose the CaSiO3_MgSiO3 FACT figures (*.fig)
file from the FactSage\Figures folder.

File preview appears when filename changes
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The CaSiO3 - MgSiO3 pseudo-binary phase diagram
Double-click in the area outside the graph frame area, press «F5» or select Edit > 
Frame and Scale… from the Menu Bar to open the «Frame and Axis» dialog box. 

Graph frame area
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Editing Frame and Axes

Figure permits to manipulate the frame and the axes of a diagram.

The following two slides show how this is done.
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The Frame and Axis Window
Figure title, subtitle 
and logo edition

Info selection
(date and filename)

Frame
borders selection

Y-Axis
edition

X-Axis
edition

Grid edition
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Editing the frame and the axes
Making changes:

1. Modification of the figure title

3. Addition of a subtitle

4. Removal of a logo

2. Addition of the date and the 
filename at the top right corner

5. Modification of 
the axes titles

6. Change (on both axes):
• of the increments
• of the font of the 

labels
• of the width and the 

color of the lines

8. Modification of the format 
of the labels on the X-axis

9. Modification of the labeling 
increment on the Y-axis

7. Addition of grid and 
specification of the 
separation and the 
width of the lines
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Saving the edited diagram and viewing the result

Once all modifications of a diagram have been made it is possible to 
store this diagram for further use. Various output formats are 
available such that a diagram can be directly transferred to Windows 
based text editors for report writing or to PowerPoint for the 
generation of computer based presentations.

A further task that can be performed with the Figure module is the 
numerical inspection of a diagram. The cursor can be used for the 
purpose, and it is also possible to use a zoom window in order to 
have a better means for positioning of the cursor in the diagram.
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Saving the results of the edition of the frame and the axes

Crosshairs can be viewed when you press the 
mouse left button and maintain it (the option 
Coord. Lines (View menu) has to be checked).  

• FACT figures (*.fig), ASCII files, 
which are editable with Figure;

• Windows (*.bmp, *.emf and 
*.wmf) which are exportable files.

Here, you have the choice  between 
two kinds of file types:

It is strongly recommended to save 
the figure under .fig format before 
saving under any other format.
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« Save all types » option
You can now save your figure in all 4 formats (*.fig, *.bmp, 
*.emf and *.wmf) by enabling the «Save all types» option. 

To enable this option, go 
in the File menu and click 
on Save all types.

A checkmark in front of 
the option’s name indicates 
that the option is enabled.

The next time you select the « Save » or 
the « Save as… » command you save 
your file in 4 formats (*.fig, *.bmp, *.emf
and *.wmf) in the directory of your choice. 
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Viewing options
Show / hide the Edition Tool Bar

Show the crosshairs
Show in black and white

Magnifying glass
(6X current zoom),
• bull’s eye enabled,
• fixed mode

(instead of proportional)

Maximise the figure in the window
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Adding and editing experimental data points

The following four slides show how to use a diagram generated with the 
Reaction module as a basis into which experimental data are added.
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Obtaining a figure file from the Reaction program
Heating of 1 mole NaF from 298.15 K to T = 300 K 
to 1800 K under P = 1atm (standard state)

Graph of the enthalpy ∆H in 
function of the temperature T
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Adding experimental data from an Excel file to the Figure program
You select and Copy your data points 
from the Excel® file and you Paste it in 
the Figure program.
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Editing the experimental data:  Selection
Choose your data 
representation:  
symbol or line.  
Press «OK». 

Define your Symbol:
• Color:  Red
• Type:  Small circles

(filled)
• Size: 6

Press «Error bars   ».
Make your choice of Error bars properties:  
type, thickness, color and dimensions.
Press «OK».
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Editing the experimental data:  Output

Press «OK» in the Define Symbol widow.
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Adding a legend into a figure

Figure permits the addition of a legend into a diagram.

The following two slides show how to do that.
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Adding a legend or text to your Figure
To open the Add Label window, you can:

• click on the Add Label icon on the 
edition tool bar,

• select Text… from the Add menu or
• press «F2» on the keyboard.

Type:
• your Text;
• the Coordinates of the 

anchor of the text box
(here X=400 and Y=120000);

• the Angle of the text box;
• the Alignment of the text box;
• the text Font, size and color.

Press «OK».
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An Enthalpy ∆H vs temperature T(K) graph 

Look at the coordinates of the 
pointer (this point is at the left 
end for the «left justify» label).

The object selected is highlighted, 
circled and its identification appears in 
the selected object identification box.
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Adding and editing symbols to a figure

Figure permits the addition of symbols into a diagram. Symbols that 
have been added may also be edited.

The following three slides show how to make use of the adding and 
editing of symbols.
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Adding a symbol to your Figure

Select:
• the 
Coordinates of 
the symbol 
(here X=375
and Y=120000);

• the Color, the 
Type and the 
size;

•and the Error 
bars.

Press «OK».

To open the Add Symbol window, you can:
• click on the Add Symbol icon on the 

edition tool bar,
• select Symbol… from the Add menu or
• press «F1» on the keyboard.
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Editing all symbols together
Left click on a symbol to open a pop-up menu, then select Edit.  The Edit symbol
window will appear (shortcut: double-click on a symbol will do the same).
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Editing all symbols together:  Results

Making changes:
•Error bars removed:  «shown» box unchecked
•Color:  blue
•Type:  diamond (half-filled bottom)
«changed all related symbols» box checked
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Adding and editing lines

The Figure module permits the addition of lines into an already 
existing diagram. Once the line has been added it is also possible 
to edit it, e.g. in terms of the line color, line thickness etc.

The following four slides show how to make use of the adding and
editing of lines.
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Adding lines to a figure using the mouse

To add a line using the mouse:
• Select the «Open a new line» button (the pointer is now a cross);
• Move the pointer to the location of the first point of the line and click;
• Repeat for the next points.

And close the line by pressing on the «Close the new line» button 
in the Edition toolbar or the Close line button in the
Close New Line window.  This will open the Add Line window.
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The Add Line (Edit Line) window features
Enter a line number Enter a line name

Check to put a symbol at every 
calculated point of the line

Click to change symbol type

Check to enable the drag-
and-drop of the selected line

Enter the width of the selected line

Copy the selected object

Change the  selected point by the new value

Split the line from 
the selected point

Select the line appearance

Click to change the color of 
the selected line and symbol

Delete the selected object

Insert a new point before the selected point

Clicking on the Add Line button
or selecting Add > Line… also
opens the Add Line window and you 
can enter the points coordinates of
lines using the keyboard.
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Editing in the Add Line (Edit Line) window

Making few changes:
1. Indexing and labeling the line;
2. Inserting a point bebore point #2;
3. Changing the coordinates of the four points;
4. Changing the color, style and width of the line;
5. Splitting line #1 at point #3;
6. Copying line #2, indexing and naming the new line

(3 and vertical), changing coordinates and
unchecking «disable dragging» of line #3

Step 5:
Before splitting

Step 5:
After splitting
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Result of the lines’ edition and Drag-and-Drop feature

Click and hold down the mouse right button and drag the 
selected object (a symbol, a label or a line [if it is drag enabled]) 
to its new location and then release the mouse right button.

Identification of the selected object.
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Changing Scale

The following two slides show how the Change Scale option is 
called and applied in adjusting the axes variables of a diagram.
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The Change Scale window
For example, you want to 
change enthalpy values from 
joules to calories and change 
temperature values from 
Kelvins to Farenheit degrees.

1. From the Menu bar, select:  
Edit > Change Scale… to 
open the Change Scale
window

For the X-axis, the temperature:
1.8 × [T(K) -273.15] + 32 = T(°F)
or 1.8 × T(K) - 459.67 = T(°F)

For the y-axis, the enthalpy:
∆H(J) × [1 Kcal / 4184 J] = ∆H(Kcal)
or ∆H(J) × [2.39 × 10-4] = ∆H(Kcal)

2. Enter the operation you want to perform.

3.  Press «OK»
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Change scale: Result

Of course, you can edit the 
frame and the axes again.
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Using Figure in the Phase Diagram module

One of the major uses of the Figure module is in conjunction with 
the Phase Diagram module.

In that context the Figure module is called/opened automatically
when the calculation of the phase diagram begins.

After the diagram is complete the Figure module is used to post-
process the diagram on-line. Labels can be generated and fixed 
to a user selected position in the diagram, tie-lines can be 
calculated and plotted (if applicable), it is even possible to use 
the cursor to generate input for a point equilibrium calculation for 
a given x-y position in the diagram.
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Calculating and drawing a binary Phase Diagram

Calculating the MgO-CaO phase 
diagram using the Phase Diagram
program.  (For details see Phase
Diagram help, sections 4 and 15)

Important:
To enable the 2-phases tie-lines mode, you must 
check the box show tie-lines in the Parameters
window of the Phase Diagram program.
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Phase diagram:  Figure output
By default, the stable phases label mode is enable.  Click on the 
figure to add the names of equilibrium phases at the cursor position.

We have a phase diagram in color in 
which the status window, the tie-lines
and the labels are shown.
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Labeling phase domains, drawing tie-lines and showing results of calculation

The normal edition mode 
toolbar appears when the normal 
edition mode is enabled

With a few mouse clicks,
We label each domain           ,  
draw a tie-line at 2160 K      , 
show the proportion and the 
composition of the phases at 
XMgO= 0.5 and T = 2160 K      .
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A Ternary (Gibbs triangular) diagram

The following two slides show how a ternary isothermal phase 
diagram (Gibbs triangle) is pepared and plotted.

It is also shown that a group of items (here all phase boundaries) 
can be treated with an «ensemble» command, for example to 
change the color of all members of the group.
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Calculating and drawing a ternary Phase Diagram

Calculating the LiF-KF-NaF phase diagram using the Phase Diagram program. 
(For details see Phase Diagram help, section 12)
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Ternary coordinates

You have the same features
as on binary phase diagrams:  
labels, tie-lines, …
Here, we change all the line 
color to red.

You also have 
ternary coordinates.

This figure is saved 
[File > Save as…]
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Superimposed diagrams

The following two slides show how to make use of the Superimpose
feature of Figure.

It is often useful to be able to draw diagrams in which a series of 
curves appear which depend on one particular parameter. The value 
of this parameter is different for each diagram, but the type of
diagram is the same for a whole series.

As an example an overlay of two isothermal ternary phase diagrams 
is generated in which the temperature is the parameter.

NOTE that this feature is particularly useful if so-called liquidus 
projections are to be generated.
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The Superimposed Figure feature

Calculating another isotherm, at T=650°C, of 
the LiF-KF-NaF phase diagram using the 
Phase Diagram program.  

Select the «Superimposed Figure»
fonction from the normal edition 
mode toolbar or from the menu 
bar:  File > Superimpose…
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Superimposed figures
Select the figure to be superimposed on the previous one and press «Open»

14.2
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